Составить программу на pascal: 1) для нахождения суммы 2^2+4^2+ 2) для нахождения всех делителей числа n

kadnikovaliza kadnikovaliza    1   01.09.2019 23:20    2

Ответы
Сніжана111 Сніжана111  06.10.2020 10:43
Var
   n,i:integer;
   S:real;
Begin
Write('n = ');ReadLn(n);
WriteLn('1)');
S:=0;
i:=2;
While i<=n do
   Begin
   S:=S+i*i;
   i:=i+2;
   End;
WriteLn('S = ',S);
WriteLn('2)');
Write(n);
i:=n div 2;
While i > 0 do
   Begin
   if n mod i = 0 then Write(' ',i);
   i:=i-1
   End;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика