Составить программу, которая заполняет одномерный массив из 20 элементов случайными целыми числами от 1 до 99, а затем определяет, сколько в массиве имеется простых чисел (простым числом называется такое, которое делится только на единицу или само на себя). процесс определения того, является ли число простым, оформить в виде отдельной процедуры.

бббб9 бббб9    2   28.08.2019 05:50    5

Ответы
kokos22850 kokos22850  09.08.2020 23:54
Procedure P(Const A:integer; Var p:integer);
Var
   K:real;
   d:integer;
Begin
if A > 1 then
   if (A = 2)or(A = 3) then p:=p+1
   else
      if A mod 2 <> 0 then
         Begin
         K:=Sqrt(A);
         d:=3;
         While (d<K)and(A mod d <> 0) do
            d:=d+2;
         if A mod d <> 0 then
            Begin
            p:=p+1;
            Write('(простое)')
            End
         End;
End;
Const
   N = 20;
Var
   A:array[1..N] of integer;
   i,k:integer;
Begin
Randomize;
k:=0;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(99)+1;
    Write(' ',A[i]);
    P(A[i],k);
    End;
WriteLn;
WriteLn('Кол-во простых чисел в массиве: ',k);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика