Составить программу,которая заменяет все нечетные числа на 46(массив из a целых чисел формируется случайным образом в интервале [16; 28]

1Ліночка1 1Ліночка1    2   14.09.2019 03:50    3

Ответы
Dasha12357123 Dasha12357123  07.10.2020 13:22
1.
begin
  var a:=ReadlnInteger('a =');
  var x:=ArrRandom(a,16,28); x.Println;
  x:=x.Select(x->odd(x)?46:x).ToArray;
  x.Println;
end.

2.
const a=10;
var x:array[1..a] of integer;
i:integer;
begin
Randomize;
for i:=1 to a do begin
 x[i]:=random(13)+16;
 write(x[i]:3);
 end;
writeln;
for i:=1 to a do
 if x[i] mod 2<>0 then x[i]:=46;
for i:=1 to a do write(x[i]:3);
writeln;
end.

Пример:
21 20 27 26 17 18 27 23 26 25
46 20 46 26 46 18 46 46 26 46
ПОКАЗАТЬ ОТВЕТЫ
alex54789089 alex54789089  07.10.2020 13:22
ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ Матем ИЗ "...\Отделы\Числа\";

ПОСТ
  A = 100;

ПЕР
  массив: РЯД A ИЗ ЦЕЛ;
  сч: ЦЕЛ;

УКАЗ
  ОТ сч := 0 ДО A - 1 ВЫП
    массив[сч] := УЗК(ВШИРЦЕЛ(Матем.случ() * 12)) + 16
  КОН;
  ОТ сч := 0 ДО A - 1 ВЫП
    ЕСЛИ НЕ   ЧЕТ(массив[сч]) ТО массив[сч] := 46 КОН
  КОН

КОН Задание.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика