Составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20; 30]

ttyt3 ttyt3    1   27.05.2019 04:40    4

Ответы
Markich7770777 Markich7770777  23.06.2020 21:20
Program Task;
Const n = 15;
Var a: Array [1..n] of Integer;
i: Integer;
Begin
    Randomize;
    For i := 1 To n Do
        a[i] := Random(30 - 20 + 1) + 20;
    WriteLn('Массив:');
    For i := 1 To n Do
        Write(a[i], ' ');
    WriteLn;
    For i := 1 To n Do
        If a[i] Mod 2 = 1 Then
            a[i] := 31;
    WriteLn('Результат:');
    For i := 1 To n Do
        Write(a[i], ' ');
    ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика