Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в pascal abc. составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в pascal abc.

Golinskaya2002a Golinskaya2002a    3   24.05.2019 13:30    0

Ответы
fhlurx fhlurx  20.06.2020 10:19
1) program zad1;
var a: integer;
begin
a:=29;
while a>0 do
begin
if (a mod 2=1) then
writeln(a);
a:=a-1;
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Relig1d Relig1d  20.06.2020 10:19
Var i:integer;
begin     
i := 30;     
while (i >= 1) do     
begin         
if (i mod 2 = 1) then           
writeln(i);       
 i := i - 1;     
end;
end.

2)
var i, a: integer;
begin   
for i:=0 to 30 do       
if (i mod 2 = 1) then         
a := a + i;   
writeln(a);
end.

Удачи:)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика