Составить программу, которая вычисляет произведение сомножителей: (1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)… вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6. в ответе написать количество сомножителей для данного вычисления. в ответе указать только число, например, 15

Гогич Гогич    3   18.06.2019 15:40    2

Ответы
tiamaressp035gw tiamaressp035gw  15.07.2020 08:34
Var i, ans : integer;
pr : real;
begin
    i := 1;
    pr := 1;
    ans := 0;
    while (pr <= 3.6) do begin
        pr *= (1 + 1 / (i * i));
        i := i + 1;
        ans := ans + 1;
    end;
    writeln(ans);
end.

48 сомножителей
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика