tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу которая
Составить программу которая выбросит из записи числа n все цифры равные 1, оставив при этом прежним порядок остальных цифр. пример 5101234-50234
ladygum78
3 17.07.2019 22:30
2
Ответы
ElzaMi13
03.10.2020 06:41
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
var s:=ReadlnString.Where(x->x in ['0'..'9']);
var r:=s.Where(x->x<>'1').Println('');
end.
Тестовые примеры:
5101234
50234
3,1415926535897932384626433832795028 - первые знаки числа ПИ
345926535897932384626433832795028
98765432111111111110000111111000001111111123456789
9876543200000000023456789
ПОКАЗАТЬ ОТВЕТЫ
Kmamsmajfkf
03.10.2020 06:41
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
string s, ans;
cin >> s;
for(int i = 0 ; i < s.size() ; i ++)
if( s[i] != '1' )
ans.pb( s[i] );
cout << ans;
ret(0);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
freeSkoM
04.09.2019 19:50
Какая из наук считается «основательницей» системно-информационного взгляда на природу?...
leafpool1
10.12.2020 20:18
Дана электронная таблица. Настя скопировала формулу из ячейки В6 в ячейку С6. Выберите формулу, которая будет находиться в ячейке С6 (это было к первому скрину)...
настя7187
10.12.2020 20:19
Максимальная скорость передачи данных в локальной сети 100 Мбит/с. Сколько страниц текста можно передать за 1 сек если 1 страница текста содержит 50 строк и на каждой строке...
ZzzGoshAzzZ
10.12.2020 20:19
В первой строке исходных данных записан оператор описания констант в языке Паскаль, например, Const M = 5; Во второй строке содержится описание нескольких (не более трёх) одномерных...
Dzdze
10.12.2020 20:20
1. Нарисовать дерево каталогов A:\Картинки\0016.jpeg A:\ Картинки\02.gif A:\ Картинки\Мои\солнце.jpg A:\ Игры\hallo.exe A:\ Игры\Программы\roo.exe A:\ Игры\babytype.gif A:\ Документы\чудо.pdf...
Аліна23456
10.12.2020 20:21
Алимхан учится в 8 классе. При изучении темы: «Измерение информации» на уроке информатики он спросил учителя о том, какой объем занимает учебник «Информатики». Учитель предложил...
рябиночка17
10.12.2020 20:21
3. ответьте на вопросы теста: 1. После выделения части рисунка и выбора команды Копировать в графическомредакторе этот фрагмента) исчезнет с экранаб) останется на экране и будет...
мам2017
15.05.2020 09:56
Имеется IP-сеть 223.224.201.0. Системный администратор Чебурашка по заданию Главного администратора Геннадия ака Крокодил разделил сеть на части. По регламенту назначения адресов...
тикон3
15.05.2020 09:56
1. Условие задания:Что получится в результате работы фрагмента программы?m:=17;for i:=1 to 7 dom:=m-6;writeln (m);2.Условие задания:Что получится в результате работы фрагмента...
лапка27
15.05.2020 09:57
Напишите буквы П и А с векторов...
Популярные вопросы
Как называются огромные чёрные шары в воде, которые взрываются, если до них...
1
Опишите характер призрака оперы как он передаётся в музыке какие эмоции он...
3
Сообщение об одном из этапов развития российского государства...
3
Сделать полный синтаксисичнский анализ предложения и проверьте запятые ) я...
1
Мешок с картошкой массой 50кг поднимают из погреба глубиной 2м,а затем перетаскивают...
1
Дана непустая последовательность целых чисел, оканчивающаяся нулем(ноль элементом...
3
Мне . сократить дроби: б) 5×12/24×15= а) 4×18/8×36= в) 13×15×48/16×130×12=...
3
Как вы думаете каким был человек написавший ,,слово о полку игореве ‘’ сочинение...
1
7класс проверочная работа по теме: «предлог» 3 вариант . запишите предложения,...
2
Перечень событий (процессов) а)смута б)революция в в)опричнина г)раскол православной...
2
begin
var s:=ReadlnString.Where(x->x in ['0'..'9']);
var r:=s.Where(x->x<>'1').Println('');
end.
Тестовые примеры:
5101234
50234
3,1415926535897932384626433832795028 - первые знаки числа ПИ
345926535897932384626433832795028
98765432111111111110000111111000001111111123456789
9876543200000000023456789
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
string s, ans;
cin >> s;
for(int i = 0 ; i < s.size() ; i ++)
if( s[i] != '1' )
ans.pb( s[i] );
cout << ans;
ret(0);
}