Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное среди них.ничего кроме этого программа выводить не должна. при использовании системы free pascal для представления целых чисел используйте тип longint. надо сделать в pascal

ThePashka ThePashka    1   18.05.2019 13:00    1

Ответы
SpaceRZX SpaceRZX  11.06.2020 19:23

var

  a, b, c, d, t1, t2:longint;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  write('c = '); readln(c);

  write('d = '); readln(d);

  if a < b then

    t1 := a

  else

    t1 := b;

  if c < d then

    t2 := c

  else

    t2 := d;

  if t1 < t2 then

    writeln('Min = ', t1)

 else

    writeln('Min = ', t2);

  readln;

end.

 

ПОКАЗАТЬ ОТВЕТЫ
Adln48 Adln48  11.06.2020 19:23

var

a,b,c,d,max:longint;

begin

  read(a); read(b); read(c); read(d);

  min:=a;

  if min>b then min:=b;

  if min>c then min:=c;

  if min>d then min:=d;

  writeln(min);

end.

 

Программа работает, проверено мной.)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика