Составить программу которая складывает введенные числа (3 числа) program z1; var s: string ; a,b,c,p,r,t,y,z,x,u,o: integer; begin writeln ('ввежите пример '); readln (s); p: =pos('+',s); a : = val (copy(s,1,p-1),a,r); delete (s,1,p); t: =pos('+',s); x: =val (copy(s,1,t-1),y,r); delete (s,1,t); z: = val (copy(s,1,z-1),u,r); o: =a+t+x; writeln ('сумма равна',o); end. вот что получилось но чет не робит исправьте кто может

Алля111 Алля111    1   07.08.2019 08:10    4

Ответы
Semev Semev  04.10.2020 02:39
Program z1;

var s:string ;
a,b,c,p,r,t,y,z,x,u,o: integer;

begin

writeln ('введите пример ');

readln (s);

p:=pos('+',s);

val (copy(s,1,p-1),a,r);
delete (s,1,p);
p:=pos('+',s);
val (copy(s,1,p-1),y,r);
delete (s,1,p);
val (s,u,r);
o:=a+y+u;
writeln ('сумма равна',o);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика