Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы массива на значение максимального элемента. требования : n - не более заполнения массива - ввод значений с клавиатуры; наличие в массиве положительных и отрицательных элементов; вывод сопровождается: исходный массив, значение максимального элемента, печать массива после внесенных в него изменений, дружественный интерфейс

polina9898798788 polina9898798788    3   18.09.2019 13:50    2

Ответы
Павлик8089 Павлик8089  08.10.2020 00:09
var a: array[1..999] of integer;
var n, max: integer;
begin   
read(n);
    for var i := 1 to n do begin 
       read(a[i]); 
   end;   
for var i := 1 to n do begin   
    if a[i+1] > a[i] then 
      max := a[i+1];   
    write(a[i] + ' '); 
       if i = n then writeln;
    end;   
 writeln(max); 
  for var i := 1 to n do begin
      a[i] += max;   
      write(a[i] + ' '); 
  end;
end.
Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы м
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика