Составить программу которая считывает целое число. если оно чётное и положительно увеличить его в два раз , в противном случае увеличить в 10 раз.

azatnacu azatnacu    1   18.09.2019 01:01    2

Ответы
могистер3271 могистер3271  26.08.2020 22:29
C#:
    class Program
    {
        static void Main(string[] args)
        {
            int a;
            a = Convert.ToInt32(Console.ReadLine());
            if (a % 2 == 0)
            {
                a *= 2;
            }
            else
            {
                a *= 10;
            }
            Console.WriteLine(a);

            Console.ReadLine();
        }
    }

Pascal:

program n;
var
a: integer;
begin
readln(a);
if a mod 2 = 0 then
a *= 2
else
a *= 10;
writeln(a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика