tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу
Составить программу которая считает колличество нулевых элементов массива b
НикаиВикаСестры1110
2 19.07.2019 18:50
1
Ответы
владислав186
22.09.2020 16:03
Вот пример реализации на языке паскаль:
program nullarray;
const
max = 100;
var
arr : array[1..max] of integer;
i, num, summ : integer;
begin
{ заполняем массив случайными числами }
randomize;
for i:=1 to max do arr[i]:=random(10);
{ ищем нулевые элементы и считаем их }
summ:=0;
for i:=1 to max do begin
num:=arr[i];
if num=0 then summ:=summ+1;
end;
writeln(summ);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
omim
04.09.2020 22:26
Тимур живёт на третьем этаже многоэтажного дома. Это сообщение несёт 4 бита информации. Сколько этажей в доме Тимура?...
alliance234
15.02.2022 04:32
2 х, если -3 x y= Ах, Іх, если о x о...
Даня324556
15.02.2022 04:34
Биба и боба 10 html body text = blue table borderbordercolor = greenwidth = 100% align = center bgcolor yellow caption align = bоttоm H2 Информацияоб учениках /H2 /caption tr th...
TIPOcrytou
15.02.2022 04:37
Pascal Определить результат целочисленного деления первой цифры (цифры десятков) на вторую цифру (цифру единиц) двухзначного числа, введённого с клавиатуры...
ernis024
15.02.2022 04:38
Данные двоичный код:11100001 Какие клетки будут закрашены чёрным цветом?...
mulin2000462345
15.02.2022 04:38
Назови правила применения и записи арифметических действий в программе Scratch...
сема891
15.02.2022 04:39
от напишите наименьшее двухзначное число х, для которого истинно высказывание : НЕ (х =40) И (первая цифра нечетная)...
yjtkf
30.11.2020 13:41
1.Как отформатировать шрифт и абзац в текстовом документе? 2.Как вставить рисунок и изменить его положение в документе? 3.Как создать различные виды списков? 4.Что такое колонтитул?...
АкадемеG
30.11.2020 13:41
висловте припущення,коли варто застосовувати голосовий пошук .Для перевірки власних припущень знайдіть потрібні відомості в Інтернеті....
мадина3031
30.11.2020 13:36
Рассматривается множество целых чисел, принадлежащих числовому отрезку [2057; 9414], которые удовлетворяют следующим условиям: − сумма последних двух цифр не равна 5; − не кратны...
Популярные вопросы
1. В каком слове верно выделена буква, обозначающая ударный гласный звук? А....
3
Які процеси демократизації передували розпаду СРСР? Які головні юридичні документи...
1
Спишите предложения, вставляя пропущенные буквы и раскры вая скобки. Назовите...
1
ЯЗЫК ПИТОН! Суперчисла Суперчислом называется число, являющееся суммой двух простых...
3
Из данных ниже слов выберите существительные, показателями которых являются суффиксы:...
1
1. О.Сүлейменов кім 2. Ол қайда туды? 3. Әкесі кім болды? 4. Қайда оқыды? 5....
2
В одном из приведённых ниже предложений НЕВЕРНО употреблено выделенное слово....
1
Сочинение рассуждение на тему легко ли быть человеком? по произведению Собачье...
1
Охарактеризовать взаимное влияние экологических факторов. 2. Задание выполнить...
2
Какая душа была у Вальки Кудрина?...
3
program nullarray;
const
max = 100;
var
arr : array[1..max] of integer;
i, num, summ : integer;
begin
{ заполняем массив случайными числами }
randomize;
for i:=1 to max do arr[i]:=random(10);
{ ищем нулевые элементы и считаем их }
summ:=0;
for i:=1 to max do begin
num:=arr[i];
if num=0 then summ:=summ+1;
end;
writeln(summ);
end.