Составить программу которая рассчитывает высоты проведенной к гипотенузе прямоугольного треугольника если известны его катеты значения катетов запрашиваются и вводятся с клавиатуры. ста

vlad2380 vlad2380    2   19.07.2019 16:50    1

Ответы
ирина1834 ирина1834  15.09.2020 19:21
Высоту можно определить по известной формуле (если проблемы с этим - см. Интернет или задайте вопрос в Геометрии, чтобы формулу вывели):
\displaystyle h:= \frac{ab}{ \sqrt {a^2+b^2}}, где a,b - катеты

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var a,b:real;
  Write('Введите катеты через пробел: '); Read(a,b);
  Writeln('h=',a*b/sqrt(a*a+b*b))
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы