Составить программу, которая позволяет найти сумму первой и третьей цифры в четырехзначном числе.

ksyhaua0406ozoo6s ksyhaua0406ozoo6s    2   09.09.2019 03:50    1

Ответы
иван1141 иван1141  20.08.2020 23:49
Program test_sum;
begin
var inp_num : integer;
readln (inp_num);
var a, b : integer;
a := inp_num[0];
b := inp_num[2];
var res := a + b;
writeln ("Сумма 1 и 3 цифры равна: ", res);
end.
ПОКАЗАТЬ ОТВЕТЫ
Маринааамурр Маринааамурр  20.08.2020 23:49
#include <iostream>

using namespace std;

int main(){
system("chcp 1251");
int n;

cout<<"введите 4-значное число";
cin >> n;

int first = n/1000; // первая цифра
int third = (n%100)/10;

cout << "\nответ = " << first + third << endl;
system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика