Составить программу которая поставит максимальный элемент массива на первое место(массив из 10 целых случайных чисел)

marina2355 marina2355    2   06.06.2019 22:20    1

Ответы
bochar2001roody bochar2001roody  01.10.2020 21:06
Var
  i,max,m:integer;
  a:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(50);
  write(a[i],' ');
  if a[i]>max then
     begin
     max:=a[i];
     m:=i;
     end;
  end;
writeln;
writeln('Измененный массив:');
i:=a[1];
a[1]:=a[m];
a[m]:=i;
for i:=1 to 10 do write(a[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика