Составить программу ,которая последовательно циклически запрашивает 40 целых положительных чисел и назодит минимальное значение среди чётных чисел. минимальное значение вывести на экран

Darjana13 Darjana13    2   21.04.2019 16:04    4

Ответы
fima9 fima9  08.06.2020 03:42

program nnn;

uses crt;

var

i,m:integer;

a:array[1..40] of integer;

begin

for i:=1 to 40 do

begin

read(a[i]);

end;

m:=a[1];

for i:=1 to 40 do

begin

if a[i] mod 2 = 0 then if m>a[i] then m:=a[i];

end;

writeln(m);

end.

если без массива:

program nnn;

uses crt;

var

i,c,m:integer;

begin

for i:=1 to 40 do

begin

read(c);

if i=1 then m:=c;

if c mod 2 = 0 then if m>c then m:=c;

end;

writeln(m);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика