tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу, которая
Составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.
KristinkaOvchin
2 26.06.2019 22:10
1
Ответы
Sonni18
21.07.2020 15:52
var
a,b,c,g : integer;
// a,b,c - стороны
begin
readln (a,b,c);
// g - находим гипотенузу (наибольшее из чисел)
if a > b then
begin
if a > c then
g := a
else
g := c
end
else
if b > c
then
g := b
else
g := c;
// Если треугольник прямоугольный, то
// сумма квадратов катетов равна квадрату гипотенузы
if (sqr (a) + sqr (b) = sqr(g))
or (sqr (a) + sqr (c) = sqr(g)) then
writeln ('Yes')
else writeln ('No');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Shariknt
20.06.2019 07:00
Ввести массив a1,. расположить ненулевые элементы по убыванию...
liskotovich
15.09.2020 09:55
1. Ақпарат арнасы деген не? 2. Ақпараттың қандай түрлері бар? 3. Ақпарат көздеріне нелер жатады? 4. Қандай ақпарат арналарын білесің? 5. Ақпарат қандай қасиеттерге...
basirovdanil
15.09.2020 09:55
1.Егер қатты дискіде 1000 суретті jpq кеңейтілуімен сақтасақ, онда ол дискіде қанша орын алады? 2.Компьютерлік графиканы не үшін сығылған түрде қолданады?...
Lerika51640
15.09.2020 10:17
2. Выполните вычитание двоичных чисел: а) 1010 - 110 б)1100 - 11 в) 1011 - 101,11 г) 11011,11 - 101,01 д) 1111 - 10,11 е) 1101,101 - 1001,01 ж) 10010,01 - 111,1 з)110001...
Aigggggg
15.09.2020 10:18
1. Какие виды информации можно выделить по восприятия: 1) ...2) ...3) ...5) ......
13913
22.02.2020 20:35
Почему удобно использовать готовые шаблоны?ИНФОРМАЦИОННО КОММУНИКАЦИОННЫЕ ТЕХНОЛОГИИ...
bosiy01
22.02.2020 20:30
решить эту не посильную задачу...
kamilyusupov123
22.02.2020 20:28
В программе кумир начертите эту фигуру и к ней блок-схему ВСЕ !!...
AlinaSh25
22.02.2020 20:21
ЛЮДИ ХОТЯ БЫ 2 ИЛИ 3 ПРОГРАММЫ ДЛЯ PHYTON 8 КЛАСС 1Напишите программу, которая вводит с клавиатуры координаты x, y, величину радиуса r и рисует окружность на холсте...
киска555555544
26.05.2021 18:42
Постройте таблицу истинности для данного логического выражения: ¬X1∨X2→¬X1∧X2....
Популярные вопросы
Как полюбить учебу и учиться с удовольствием?...
2
Проверить данные предложения на пунктуацию. 1) этот человек работал...
3
Изменяется ли внутренняя энергия тела в момент падения...
2
Где скачативать учебники за 9 класс на планшет в казахстане ...
1
Всего яблок ыли 1) 8 2) 2 3) 1 4) 5 5) 6 19. альбина расставила...
1
Директору зоопарка 15 разных животных. директору хочется, чтобы...
2
Утром со школьного двора отправились в туристический поход. вечером...
2
Напешите срченение картинн и. шевиндровой на терассе...
3
Найти координаты центра и радиус окружности заданной уравнением:...
1
Букет из двух тюльпанов и одного нарцисса стоит 40 руб. причем...
3
a,b,c,g : integer;
// a,b,c - стороны
begin
readln (a,b,c);
// g - находим гипотенузу (наибольшее из чисел)
if a > b then
begin
if a > c then
g := a
else
g := c
end
else
if b > c
then
g := b
else
g := c;
// Если треугольник прямоугольный, то
// сумма квадратов катетов равна квадрату гипотенузы
if (sqr (a) + sqr (b) = sqr(g))
or (sqr (a) + sqr (c) = sqr(g)) then
writeln ('Yes')
else writeln ('No');
end.