Составить программу которая определяет количество чисел в интервале от 100 до 1000 одновременно делящихся на 5 и 21

starkoviv23 starkoviv23    3   20.07.2019 00:10    1

Ответы
mariaa987 mariaa987  03.10.2020 08:21
Пример, когда лучше сначала подумать, а потом писать программу.
Если число делится одновременно на 5 и 21, то оно делится и на их произведение, т.е. на 105.
Количество таких чисел на указанном интервале может быть найдено как
\displaystyle k=\left \lfloor{ \frac{1000-105}{105}}\right\rfloor+1=9
Здесь "скобки" означают операцию взятия целой части.
Т.е. ответ уже получен, но раз требуется программа, то можно её написать так:

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  Writeln((1000-105) div 105 + 1)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика