Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат.

merlinina74 merlinina74    2   21.05.2019 03:10    4

Ответы
TaNyAmAkSiMeNkO TaNyAmAkSiMeNkO  01.10.2020 02:04

Pascal ABC

 

var a : integer;
begin
readln(a);
If a >= 0 then a := 2*a;
If a < 0 then a := a*a;
writeln(a)
end.

ПОКАЗАТЬ ОТВЕТЫ
Nita132 Nita132  01.10.2020 02:04

program z1;

uses crt;

var x,y:integer;

begin

clrscr;

writeln('введи число');

readln(x);

if x>=0 then x:=x*2 

else

if x<0 then sqr(x);

writeln(x);

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика