Составить программу, которая формирует массив из 5 случайных чисел от -10 до 15. а) найти элементы равные 1. б) найти индекс нечетных элементов. в) найти количество положительных элементов.

bhsdvsbvgvfsbvefe bhsdvsbvgvfsbvefe    1   09.07.2019 15:30    1

Ответы
katenok1706 katenok1706  06.08.2020 21:52
Const n=5;
var a : array[1..n] of integer;
     k,i : integer;
begin
Randomize;
 for i:=1 to n do
 begin
  a[i]:=random(26)-10;
  write(a[i],' ');
 end;
writeln;
 writeln('элементы равные 1 имеют номера:');
for i:=1 to n do if a[i]=1 then write(i:3);
writeln;
writeln('индексы нечетных элементов:');
for i:=1 to n do if a[i] mod 2<>0 then write(i:3);
writeln;
k:=0;
for i:=1 to n do if a[i]>0 then k:=k+1;
writeln('количество положительных элементов=',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика