Составить программу, которая формирует массив из 27 случайный чисел от -10 дл 15 и нечетные числа заменяет на 3, остальные уменьшает в 3 раза в паскале

SiriusSnak SiriusSnak    2   04.10.2019 00:30    2

Ответы
syuzannsckorny syuzannsckorny  09.10.2020 15:45

const n=27;


var a:array [1..n] of integer;


i:integer;


begin


write('      Исходный массив: ');


for i:=1 to n do


begin


a[i]:=random(26)-10;


write(a[i]:3,' ');


if a[i] mod 2 <> 0 then a[i]:=3


else a[i]:=a[i]-3//уменьшает на 3,т.к. при уменьшении в 3 раза получается тип real, тут или второй массив создавать или взять a[i]:=a[i] div 3 (целочисленное деление)


end;


writeln;


write('Преобразованый массив: ');


for i:=1 to n do write(a[i]:3,' ')


end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика