Составить программу, которая будет вводить пять целых чисел с клавиатуры и выводить на экран только те, которые принадлежат интервалам (0,5) и (-1,-8), либо выводить соответствующее сообщение.

smorodinovegor smorodinovegor    2   02.09.2019 15:20    2

Ответы
olgakorneva1 olgakorneva1  06.10.2020 12:32
Если требуется выводить соответствующее сообщение в случае, когда таких чисел нет:
var i, x, k : integer;
Begin
 k:=0;
 for i:=1 to 5 do begin
 readln(x);
 if ((x>0) and (x<5)) or ((x>-8) and (x<-1)) then begin
   k:=k+1;
   writeln(x);
 end;
 end;
 if k=0 then writeln('нет таких чисел');
End.

Если требуется выводить соответствующее сообщение каждый раз когда число не входит в промежуток:
var i, x : integer;
Begin
 for i:=1 to 5 do begin
 readln(x);
 if ((x>0) and (x<5)) or ((x>-8) and (x<-1)) then
   writeln(x)
 else writeln(x,' не входит в промежуток');
 end;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика