Составить программу, которая будет считывать введённое четырехзначное число. каждую цифру этого числа необходимо вывести в новой строке

Olesqqqa Olesqqqa    1   26.09.2019 22:01    2

Ответы
Denchik15070 Denchik15070  16.08.2020 22:51
// PascalABC.NET

begin
   var num: integer;
   while true do
   begin
      num := ReadlnInteger('введите 4-х значное число, num =');
      if (num > 999) and (num <= 9999)
         then break;
   end;
   
   var str := num.ToString;
   
   foreach var x in str do
      Println(x)
end.
ПОКАЗАТЬ ОТВЕТЫ
Ваниш20 Ваниш20  16.08.2020 22:51
Var a,f:integer;
begin
write('Введите четырехзначное число: ');
readln(a);
f:=a div 1000;
writeln(f);
a:=a-1000*f;
f:=a div 100;
writeln(f);
a:=a-100*f;
f:=a div 10;
writeln(f);
a:=a-10*f;
writeln(a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика