Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 1 введите два числа: 15 16 ответ: 15+16=31 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 3 введите два числа: 5 8 ответ: 5*8=40 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 0 пока!

PAVELBOR PAVELBOR    3   27.08.2019 04:30    5

Ответы
Ahelka99 Ahelka99  05.10.2020 22:14
Var a,b,c,x:real;
begin 
repeat 
writeln('Введите тип арифм. операции (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - остановить программу'); 
readln(x); 
if x=1  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a+b;   
writeln('ответ: ',c);   
end; 
if x=2  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a-b;   
writeln('ответ: ',c);   
end; 
if x=3  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a*b;   
writeln('ответ: ',c);   
end; 
if x=4  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a/b;   
writeln('ответ: ',c);   
end; 
if x=0 then writeln('Пока!'); 
until x=0;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика