Составить программу к : сколько шансов при бросании трёх игральных костей выбросить x очков (от 3 до 18) и какие это варианты ( при вложенный циклов). pascal abc

nika716 nika716    2   06.10.2019 23:01    2

Ответы
Дина19986 Дина19986  10.10.2020 00:33

var pk,vk,tk,x,k:integer;

begin

write('x = ');

readln(x);

for pk:= 1 to 6 do

begin

for vk:=1 to 6 do

begin

for tk:=1 to 6 do  

if pk+vk+tk=x then

begin

writeln('pk = ',pk,'   vk = ',vk,'   tk = ',tk,'   ',pk,' + ',vk,' + ',tk,' = ',pk+vk+tk);

k:=k+1

end

end

end;

writeln(k,' шансов')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика