Составить программу, используя оператор repeat. вводятся числа до тех пор пока не введется 0. определить, сколько среди них положительных (включая 0) и сколько отрицательных. (числа вводятся в одну переменную в цикле).

lglglglgl lglglglgl    1   26.09.2019 05:50    0

Ответы
viktoriaedel viktoriaedel  08.10.2020 20:03
Вот так можно решить

Program M;
var i : integer = 0;
    pologitelnie : integer = 0;
    otricatelnie : integer = 0;    a : array[0..100] of Integer;
begin
    repeat
        begin
        read (a[i]);
        if (a[i]>=0) then
            pologitelnie := pologitelnie + 1
        else
            otricatelnie := otricatelnie + 1;
        i := i + 1;
        end;
    until a[i-1] = 0;
    writeln('положительных: ', pologitelnie);
    writeln('отрицательных: ', otricatelnie);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика