Составить программу, используя одномерные массивы: Найти наименьший элемент в числовом массиве М (20), который лежит в интервале [10.50]​
(Pascal)

loloh333 loloh333    2   28.01.2021 00:37    1

Ответы
toniskvortsov1 toniskvortsov1  27.02.2021 01:10

var

 m: array[1..20] of integer;

 i, min: integer;

begin

 randomize;

 min := 100;

 WriteLn('Массив:');

 for i := 1 to 20 do

 begin

   m[i] := random(100);

   Write(m[i], ', ');

   if (m[i] < min) and (m[i] >= 10) and (m[i] <= 50) then min := m[i];

 end;

 WriteLn;

 if min <> 100 then WriteLn('Минимальный элемент массива в интервале [10..50] равен ', min)

    else WriteLn('Массив не содержит элементов в интервале [10..50]');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика