Составить программу и блок схему вывода всех чисел от 1000 до 9999, в которых 1 цифра равна 4 и 2 цифра равна 3.

Rosa386433 Rosa386433    3   03.06.2019 07:00    1

Ответы
MrShkololo MrShkololo  03.07.2020 17:56
Почему-то мой ответ удалили. Напишу подробнее.
Если в чмсле первая цифра 4 и вторая цифра 3, то  числа от 4300 до 4399
На паскле программа выглядит так
var i, n: integer
begin
uses crt;
for i:= 0 to 99
begin
n = 4300 + i;
write (n);
end;
writeln;
end.
Блок-схема совсем простая, нарисуй сама.
1) Начало (в овале)
2) i = 0 (в прямоугольнике)
3) n = 4300 + i (в прямоугольнике)
4) Вывод n (в параллелограмме)
5) Проверка i > 99 ? (в ромбе). Если нет, возврат на п. 3. Если да, вниз.
6) Вывод пустой строки (в параллелограмме)
7) Конец (в овале)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика