tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу
Составить программу и блок-схему для решения . решение каждой сопроводить пояснительной запиской с описанием используемых в конструкций языка си. a[n] найти среднее элементов массива а . ai > 0; n=10
nastya02012007
1 14.07.2019 02:50
7
Ответы
Dariya078
03.10.2020 03:36
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
elenaveruaskina
25.05.2019 09:40
То,чем может отличаться один объект от другого или что может измениться у объекта при выполнении действия...
YeGoR17
25.05.2019 09:40
Информатика 8 класс найдите сумму чётных чисел и произведение нечётных чисел введённых с клавиатуры количество чисел задается с клавиатуры...
DenNewLen38
24.05.2019 07:20
Найти произведение последних 12 пятизначных чисел нацело делящихся на число 2...
AndroidBot2018
24.05.2019 07:20
Что такое информация, представленная в форме, пригодной для обработки компьютером. !...
VikaGrin1
24.05.2019 07:20
Зрение слух обоняние слух вкус это всё (два слова)...
89627750122
24.05.2019 07:20
Последованость изображений - фильмы ,мультфильмы и т.д....
belevich031197
24.05.2019 07:20
111001перевести из двоичной в дестичную систему...
jcgddrMarins
24.05.2019 07:20
На турбопаскале: хотябы пару штук 1.дано натуральное число найти сумму и произведение первых двух цифр. 2.дано n-значное натуральное число. правда ли что квадрат произведения...
GRISHINANASTYA
31.01.2021 22:02
с лабораторной по информатике...
607156
31.01.2021 22:00
Написать программу с цикла for вычисление факториала числа 29, нахождение суммы ряда s=1+1/2+1/3+...+1/n...
Популярные вопросы
За что РОМАШИН ПОЛУЧИЛ ЗВАНИЯ ГЕРОЯ...
2
Роль казачества в колонизации Казахстана эссе на 100 слов своими словами...
2
ответить на в Айтылым2- тапсырма .Сұраққа жауап бер:1. Көшпелілер...
2
1. Что понимают под постоянством состава? 2. Каков качественный и...
2
ответы на 4 5 номера 1 варианта...
3
решить Математика 7 класс...
2
Напиши текст-повествование на тему Наука Казахстана ....
1
Песня звучащая в тишене показалась мне знакомоййСинтаксический разбор...
3
відрізок BM є бісиктрисою рівнобедреного трикутника ABC(AB=BC) CBM=28°...
3
Казахский орнамент используется в одежде3. Выполни синтаксический...
1
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}