Составить программу,формирующую произвольный массив(с функции random) из 40 элементов. все элементы,большие 50,заменить на -6

MATEMATIK12345678 MATEMATIK12345678    3   21.09.2019 16:20    4

Ответы
pliza1706 pliza1706  04.08.2020 13:23
Const Sz = 40; 
var   a: array [1..Sz] of integer; 
N: integer;  
i: integer; 
k:integer; 

begin
k:=50; 
N := 40; 

for i:=1 to N do   
a[i] := Random(100); 
writeln('Элементы массива: '); 

for i:=1 to N do    write(a[i],' ');   
writeln();   

begin 
for i:=1 to n do begin 
if a[i] > N then 
a[i] := -6 end;
writeln('Заменяем элементы > 50 на -6: '); 

for i:=1 to N do   
write(a[i],' ');   
writeln(); 
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика