Составить программу для вычисления значения функции y=корень х + 5

shakjii12 shakjii12    2   30.09.2019 05:00    4

Ответы
оеавц оеавц  09.10.2020 04:40
Код (выполнен и написан на языке С++)

#include <iostream>

#include <math.h> // для функции sqrt()

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int x;

   cout << "Введите x: ";

   cin >> x;

   if((x + 5) < 0){

       cout << "Корень из отрицательного числа не вычисляется!" << endl;

       return 0;

   }

   else {

       cout << "Корень из " << x + 5 << " равен " << sqrt(x + 5) << endl;

   }

   return 0;

}


Проверка:

Введите x: 139


Корень из 144 равен 12



Введите x: -5                                      

Корень из 0 равен 0



Введите x: -6                                      

Корень из отрицательного числа не вычисляется!

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика