Составить программу для вычисления среднеарифметического n произвольных чисел. обозначения: s-сумма всех чисел; sr-среднеарифметическое n чисел; a-значение i-го числа; n-количество чисел.

привки228 привки228    2   10.08.2019 09:10    1

Ответы
hasanovratmir3 hasanovratmir3  04.10.2020 09:00
PROGRAM PR17;
  VAR
   I,N:INTEGER;
    S,SR,A:REAL:
  BEGIN
    WRITE(‘ Введите N’);
    READLN(N);
     S:=0;
       FOR I:=1 TO N DO
        BEGIN
        WRITE(‘ Введите ‘,I,’ число’);
        READLN(A);
       S:=S+A:
        END;
              SR:=S/N;
                                                                                      43 WRITELN(‘ответ: SR = ’,SR:8:3);
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика