Составить программу для вычисления квадратного уравнения x2+2x-3

Grotesk1077 Grotesk1077    3   21.09.2019 08:30    3

Ответы
LoL228LoL228LoL228 LoL228LoL228LoL228  04.08.2020 13:15
var a,b,c,d,x1,x2: real;

begin
writeln('Введите коэффициенты a,b,c:');
readln(a,b,c);
d:=(sqr(b))-(4*a*c);
if d>0 then begin
x1:=(-b+(sqrt(d)))/(2*a);
x2:=(-b-(sqrt(d)))/(2*a);
writeln('');
writeln('x1= ',x1);
writeln('x2= ',x2);
end;
if d=0 then begin
x1:=(-b/2*a);
writeln('x= ',x1);
end;
if d<0 then writeln('Корней нет!');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика