Составить программу для вычисления элементов одномерного массива по формуле: a[k]: =s*(x[i]*(exp(/ln(z[k])+(s*(exp(b[i,j])*sin(b[i,; у меня получилась такая программа: program lab6_3; var i,j,n,m,k: integer; s,s1,s2: real; a,x,z: array[1..3] of real; b: array[1..3,1..3] of real; begin s: =0; write('введите n='); readln(n); write('введите m='); readln(m); for i: =1 to n do for j: =1 to m do while (k< =2) do begin write('b[',i,',',j,']='); read(b[i,j]); end; for i: =1 to n do begin write('x[',i,']='); readln(x[i]); end; for j: =1 to m do begin a[k]: =s*(x[i]*(exp(/ln(z[k])+(s*(exp(b[i,j])*sin(b[i,; write(' ',a[k]: 0: 4); end; end. не понимаю где ошибаюсь. при вводе данных я ввожу n и m, а потом появляется b[1,1]=1 и у меня он вводит в дальнейшем только b[1,1] до бесконечности и не важно какие при этом

AlinaWinter2015 AlinaWinter2015    2   08.07.2019 20:10    9

Ответы
  06.08.2020 21:14
На Паскале:

program Program1;
var i, j, n, k: integer;
var result: real;
var array1: array [1..255] of real;
begin
     result := 0;
     write('Введите значение N (не более 255): ');
     readln(n);
     for i := 1 to n do
         begin
          write('Введите значение ', i, ' элемента массива: ');
          readln(array1[i]);
         end;
         begin
          writeln('Массив, размером - ', n, ' элементов(а):');
          for i := 1 to n do write(array1[i], ' ');
          writeln;
         end;
     for i:=1 to n do
         begin
          k := 0;
          for j:=1 to n do
          if array1[i] = array1[j] then k := k + 1;
          if k = 1 then result := result + array1[i];
         end;
     writeln('Сумма уникальных элементов массива = ', result);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика