Составить программу для вычисления длины n-мерного вещественного вектора х=(х1, х2, xn) по формуле l=)^2)+((x2)^2)+ +((xn)^2))

Настятвсердечко Настятвсердечко    2   14.06.2019 20:40    3

Ответы
ххх49 ххх49  12.07.2020 09:44
Const
  nm = 50;{максимальная размерность вектора}

var
  i, n: integer;
  x: array[1..nm] of real;
  s: real;

begin
  Write('Введите размерность вектора n -> ');
  Readln(n);
  Write('Вводите координаты вектора через пробел ');
  s := 0;
  for i := 1 to n do
  begin
    Read(x[i]);
    s := s + sqr(x[i])
  end;
  Writeln('Длина вектора равна ', sqrt(s):0:4)
end.

Тестовое решение:

Введите размерность вектора n -> 7
Вводите координаты вектора через пробел -3.54 0.532 2.6 12 -3 0 1.47
Длина вектора равна 13.2188
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика