tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для
Составить программу для вычисления длин высот треугольника , у которого длины сторон abc
бопаш
1 25.05.2019 23:10
5
Ответы
никита3467т
22.06.2020 07:20
Uses crt;
var a,b,c: integer;
h1,h2,h3,p,s:real;
begin
readln(a);
readln(b);
readln(c);
p:=(a+b+c)/2;
s:=sqrt((p-a)*(p-b)*(p-c));
h1:=2*s/a;
h2:=2*s/b;
h3:=2*s/c;
writeln(h1);
writeln(h2);
writeln(h3);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
alinapavlova
06.03.2022 09:12
Определите, что будет выведено на экран: a, b = 6, 9 a += 1 b += 2 a += b b += a a -= 2 b += a print(b)...
vlad31106
06.03.2022 09:07
1) В заданном массиве Х(N) замените нулями все отрицательные компоненты, непосредственно предшествующие его максимальной компоненте (первой по порядку, если их несколько)....
Lev1223
06.03.2022 08:48
У Алисы 9 пауков. За день она проводит несколько опытов и записывает в строку, сколько пауков понадобилось для каждого. Например, запись «022» означает, что было 3...
kotena555
15.03.2019 08:04
Запишите код программы с операторов интегрированной среды программирования для заполнения алгоритма...
Nikitka113532
15.03.2019 08:50
Какую входную информацию следует обработать, чтобы: а)выполнить площадь треугольника б)принять решение о покупке новой модели сотового телефона в) сделать сообщение...
лёля558
21.08.2019 14:40
Дано два вещественных числа a,b.найти сумму,разность,произведение,частность с команды ввода и выводим результаты следущим образом...
ksyutitova2017p0bhz4
21.08.2019 14:30
Написать программу, в которой для прямоугольного треугольника с катетом b и гипотенузой c вычисляется значение катета a...
алалайла
30.07.2019 19:10
Файловая система обеспечивает. что? информатика 3 класс...
alina20067
30.07.2019 19:10
Объясните, , паскаль! откуда взялось sr: 8: var a: array[1..8] of integer; k,i,s: integer; sr: real; begin s: =0; for i: =1 to 8 do readln(a[i]); for i: =1 to 8 do...
Ильяна111
28.06.2019 02:40
Незнайка, играя с кубиками, построил фигуру. как она выглядит сверху показано на рисунке. в клетках записаны числа кубиков, которые стоят друг на дружке на данной...
Популярные вопросы
Найдите решение систем уравнений (1273—1278): x = -7 +y, у = х...
1
Подготовить рассказ лебединной верности...
3
Перепиши́те, употреби́в местоимéние себя́ в нýжной фóрме. 1) Севи́ндж...
3
Тракторист в первый день вспахал 65% всей площади поля, во второй...
1
ответьте на все вопросы которые на фото...
2
Визначте в якому напрямку збільшується континентальність клімату...
3
Виразіть змінну у через змінну х, якщо 6х+у=8...
2
У коробці лежать 8 білих і 14 червоних кульок. Яка ймовірність...
1
Тақырып : Нағыз әже қайда? 1.Әңгіменіңфабуласы (қысқаша мазмұн)...
3
11. Какая фигура является многоугольником? фигура, не ограниченная...
2
var a,b,c: integer;
h1,h2,h3,p,s:real;
begin
readln(a);
readln(b);
readln(c);
p:=(a+b+c)/2;
s:=sqrt((p-a)*(p-b)*(p-c));
h1:=2*s/a;
h2:=2*s/b;
h3:=2*s/c;
writeln(h1);
writeln(h2);
writeln(h3);
end.