Составить программу для ввода в эвм произвольной вещественной матрицы размером m*n и вывода первого не равного заданному s элемента каждой строки. написать программу в pascalabc.net

Níkiskastarling28 Níkiskastarling28    2   12.07.2019 11:00    5

Ответы
Miniplayer Miniplayer  03.10.2020 01:49
var
  m, n, i, j: integer;
  s: real;
  a: array[,] of real;
 
begin
  write('Введите S: ');
  read(s);
  write('Введите M, N: ');
  read(m, n);
  setlength(a, m + 1, n + 1);
  writeln('Введите элементы матрицы: ');
  for i := 1 to m do
    for j := 1 to n do
      read(a[i, j]);
  for i := 1 to m do
  begin
    for j := 1 to n do 
      if a[i, j] <> s then
      begin
        writeln(a[i, j]);
        break;
      end;
    if a[i, j] = s then
      writeln('-');
  end;
end.

Пример:
Введите S: 7
Введите M, N: 3 4
Введите элементы матрицы:
7 4 3 7
3 5 1 4
7 7 7 7
4
3
-
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика