Составить программу для ввода в ЭВМ произвольной цело-численной матрицы размером M*N и определения координат и значения наименьшего по модулю элемента этой матрицы.

marinatabeleva4 marinatabeleva4    1   15.12.2020 13:57    5

Ответы
sakinaxalilova2 sakinaxalilova2  14.01.2021 14:03

m, n, i, j: integer;

 s: real;

 a: array[,] of real;

 

 write('Введите S: ');

 read(s);

 write('Введите M, N: ');

 read(m, n);

 setlength(a, m + 1, n + 1);

 writeln('Введите элементы матрицы: ');

 for i := 1 to m do

   for j := 1 to n do

     read(a[i, j]);

 for i := 1 to m do

 begin

   for j := 1 to n do  

     if a[i, j] <> s then

     begin

       writeln(a[i, j]);

       break;

     end;

   if a[i, j] = s then

     writeln('-');

 end;

end.

Пример:

Введите S: 7

Введите M, N: 3 4

Введите элементы матрицы:

7 4 3 7

3 5 1 4

7 7 7 7

4

3

-

Объяснение:

нажмите лучших ответ и лайк

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика