tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для решения
Составить программу для решения : "ввести число, обозначающее размер одной фотографии в мбайтах. определить, сколько фотографий поместится на флэш-карту объёмом 2 гбайта." язык программирования: pascal
aidargaliullin
3 28.08.2019 09:30
45
Ответы
vladdobryj071
06.10.2020 00:24
1. С вещественными числами
var
k:real;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',
Trunc(2*1024/k))
end.
Пример
Размер фотографии, мб: 3.27
На flash-card объемом 2 Гб поместится фото: 626
2. С целыми числами
var
k:integer;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)
end.
Пример
Размер фотографии, мб: 3
На flash-card объемом 2 Гб поместится фото: 682
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
mkashkan
27.09.2020 10:55
Напишите эссе на тему Техника через 100 лет . Минимум 125 слов....
tanro1
27.09.2020 10:52
ответьте очень Кто первый правильно сделает,сделаю ответ лучшим( за ответ+лучший ответ)...
DaNKoLaB
27.09.2020 10:51
Процессордың қандай сипаттамасы туралы айтылған? процессормен бір секундта орындалатын опер цпен (МГц) немесе гигагерцпен (ГГц) өлшенетін Кэш-жады Разрядтылық, Тактілік...
ааа513
27.09.2020 10:51
Эссе на тему память компьютера внешняя...
DenneD432
27.09.2020 10:49
Желілік этикет.Ұяшықтардан қажетті сөздерді таңдап,сөйлемді толықты...
yeghiazaryanhap01lbi
02.04.2021 00:42
Чему в десятичной системе счисления равно число ХХVIII, записанное римскими цифрами?...
annarom1108
02.04.2021 00:43
Нада расшифровать 04 010 115 09 113...
АлiнаКукушкiна
12.04.2021 10:14
Почему выдает ошибку встречено Writeln , а ожидалось ; решаю 1 вариантVar x, y : integer; Begin Readln (x) ; Y:=Sqrt(1+2*sqr(x)*x/1+sqr*(x)) Writeln (y) ; End...
San4ic
12.04.2021 10:15
Написати програму обчислення виразу:...
kriss200900
20.05.2019 18:40
Перевести число из 10 системы в 2,8,16 а)250(10) в)757(10) с)914,625...
Популярные вопросы
Найди значение выражения: (5,9−8):3,4 (ответ округли до десятых)....
3
Заполни пропуски с рисунка...
3
1381. Стрех лугов собрали 19,7 т сена. С первого и второго лугов со-...
3
Два задания по функциям. за лучший ответ...
1
Переведите фразы, обращая внимание на союзы both… and, as… as, than,...
1
⁸Встановіть відповідність між термінами та їх значенням. 1 «Метафізична...
2
, даю всё, что есть, умоляю...
3
4. Літеру е треба писати в усіх словах рядка * р..ф..рендум, фа..тон,...
3
Заполните таблицу, определив недостающие массы раствора, воды, соли...
2
, тест по биологии 1.Виберіть організми, що при фотосинтезі не виділяють...
1
var
k:real;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',
Trunc(2*1024/k))
end.
Пример
Размер фотографии, мб: 3.27
На flash-card объемом 2 Гб поместится фото: 626
2. С целыми числами
var
k:integer;
begin
Write('Размер фотографии, мб: '); Read(k);
Writeln('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)
end.
Пример
Размер фотографии, мб: 3
На flash-card объемом 2 Гб поместится фото: 682