tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для решения
Составить программу для решения следующей : дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. замените все отрицательные элементы максимальным. выведите на экран исходный и измененный массивы.
Anvar666
3 28.05.2019 07:40
3
Ответы
imuraveva
25.06.2020 17:59
var
i,max:integer;
ar:array[0..200] of integer;
begin
randomize;
max:=0;
for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
writeln();
for i:=1 to 200 do begin
if (ar[i] < 0) then ar[i]:=max;
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
g116663
14.05.2020 19:23
Напишите словесный алгоритм вставки звука в презентацию...
fatowka84
14.05.2020 19:23
Катети прямокутного трикутника дорівнюють a i b.Знайдіть висоту, проведену до гіпотенузи....
еденорожек12
14.05.2020 19:29
Определите значение переменной c после выполнения следующего фрагмента программы: a := -2; b := -3; a := b + a*3; if a b then c := a - b else c := b - a;...
85396ira
17.04.2020 10:17
РЕБЯТ с информатикой 8 класс, СОСТАВЬТЕ БЛОК СХЕМУ И ПРОГРАММУ НАХОЖДЕНИЯ 1,2,3,4,5,20 ПОРЦИЙ МОРОЖЕННОГО, ЕСЛИ ОНО СТОИТ 4 РУБ.50коп....
hakobov2017
17.04.2020 10:16
Эссе на тему Мой компьютер заболел...
шкода4
17.04.2020 10:16
Определите значение переменной а после выполнения алгоритма...
Molina1234
17.04.2020 10:16
Даны натуральные числа a и b, которые не превышают 1000. вывести их наименьшее общее кратное. вход: 35 21 выход...
DedMazaj
17.04.2020 10:15
Напишите то что на картинке соблюдая ЧЁРТОЧКИ, ЖИРНЫЕ, ШРИФТЫ И Т.Д ...
abekeev
19.05.2019 03:50
Проанализируйте следующий цикл: while a...
Makc857
07.03.2022 01:03
Каково биологическое значение соцветий?...
Популярные вопросы
3курицы за три дня снесли 3 яйца,сколько яиц снесут 12 12 дней?...
2
Составить предложение со словами каша в голове...
2
А)в каих случаях необходимо делать искусственное дыхание в положение на животе?...
1
Придумайте стих я иду на выборы. зарание !...
2
Разбор слова матушка как часть речи...
3
Запишите уравнения реакции для переходов: (oh)(no3)3...
2
Длина окружности, описанной около правильного многоугольника, равна 24п см, а...
2
Завтра ! напишите уравнения реакций, с которых можно осужествить превращения:...
2
Дайте оценку последствиям проникновения европейцев в другие земли и их столкновение...
3
Запишите уравнения реакций горения, если вещества , из которых состоит свеча,...
3
i,max:integer;
ar:array[0..200] of integer;
begin
randomize;
max:=0;
for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
writeln();
for i:=1 to 200 do begin
if (ar[i] < 0) then ar[i]:=max;
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
end.