Составить программу для нахождения наибольшего общего делителя четырёх натуральных чисел используя процедуру

poli145 poli145    2   07.06.2019 12:20    7

Ответы
окей126 окей126  01.10.2020 21:22
Program z1;
var a,b,c,d:integer;
procedure nod(x,y:integer;var nod2:integer);
begin
        while x<>y do begin
                if x>y then begin
                        x:=x-y
                end
                else begin
                        y:=y-x
                end
        end;
        nod2:=xend;
begin
        write('a=');readln(a);
        write('b=');readln(b);
        write('c=');readln(c);
        write('d=');readln(d);
        nod(a,b,b);
        nod(b,c,c);
        nod(c,d,d);
        writeln('nod=',d);
        readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика