tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для
Составить программу для нахождения корней квадратного уравнения ах2+вх+с
riad170310
2 28.05.2019 10:40
2
Ответы
Сельга7
25.06.2020 21:11
Uses crt;
var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Rina666
20.12.2021 09:50
Розташуйте етапи створення комп‘ютерної презентації А)Визначте структури презентації; Б)Визначення мети; В)Створення презентації в редакторі презентацій; Г)Пошук і вибір...
olgaocher
20.12.2021 10:01
Какие виды систем существуют? Материальные Нематериальные Природные Технические СмешанныеДам 30 боллов...
k0tesss
20.12.2021 10:08
очень ЧЕРЕЗ PYTHON Задано дані про оцінки кожного з n=10 учнів класу з десяти предметів. Скласти програму, яка визначає прізвище одного з учнів, який має: а) найбільшу...
imam002121
20.12.2021 10:08
составьте программу на языке Паскаль, которая формирует массив А из 15 случайных чисел, значения которых расчитываются по формуле A[i]:=6*i^2 и выводит эти элементы в...
EminRoth
14.06.2020 11:16
Какие три самые распространенные функции в MS Excel выполняются автоматически с любой выделенной областью ячеек?...
rid843
13.06.2020 11:04
сделать такую задачу на паскаль abc...
zaret1
13.06.2020 22:55
Почему выдает (встречно until , а ожидалось ; ) Var a:array[1..50] of byte; n,p, i,k,m,j,x,y,z: integer; begin writeln( Введите количество элементов ); readln(p); repead;...
hren4
13.06.2020 10:40
1. Дан фрагмент алгоритма в виде блок-схемы Определите 1) Значение переменной k после выполнения фрагмента алгоритма с построения трассировочной таблицы; 2)Тип цикла,...
Blarow
13.06.2020 10:36
5. Составить блок-схему и программу на алгоритмическом языке для данной задачи....
ghaban
13.06.2020 10:36
На языке паскаля 1.В заданном числовом массиве каждый элемент с четным индексом заменить на нуль. 2.Составьте программу табулирования функции:...
Популярные вопросы
1. Какие продукты / напитки дают нам много энергии? 2. Какие продукты...
2
Составьте и запишите 5 во к тексту The environment is all the things...
3
3(x-7)^4+(x-7)^2-8=0 сделаем замену t=(x-7)^2...
2
Укажи формулу кислоти, яка відповідає силіцій оксиду та вкажи її молекулярну...
1
Представителем какого направления является Николо Паганини...
3
Что олицетворяет образ галерника в одноименном Biрши Л. де Гонгоры?...
2
Протон рухається зі швидкістю 2*10^4м/с в однорідному магнітному полі...
3
В прямоугольном треугольнике абц катет аб на 2 больше катета ас. Найди...
2
уравнения по седьмой класс...
1
Решите кросфорд з зарубіжнох...
3
var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.