tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу
Составить программу для нахождения количества таких трехзначных чисел фибоначчи, которые делятся на сумму своих цифр нацело. программа - pascal abc
номе498
2 20.07.2019 09:50
6
Ответы
LoliPeen
03.10.2020 08:41
Var
a,b,k,s: integer;
begin
k := 0;
a := 1;
b := 1;
while b < 1000 do
begin
if b >= 100 then
begin
s := b div 100 + b div 10 mod 10 + b mod 10;
if b mod s = 0 then
k := k + 1
end;
b := a + b;
a := b - a;
end;
write(k)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kopiplay
15.09.2020 09:58
3. Фотосуреттің өлшемі 4000x1500 нүктеден тұрады. Әрбір нүктесонша түстен тұрады. Оны кодтауүшін 2 байт қажет. Берілгенфотосурет қанша орын алады?...
Nikita1356
23.01.2020 12:29
Срешением 1. считая, что каждый символ кодируется 16 битами, определите информационный объем следующего предложения в кодировке unicode: когда в товарищах согласья нет,...
отличница474
22.11.2019 18:36
Начертите блок схем площади квадрата и периметр квадрата ...
NJazira11
25.11.2020 06:21
Найдите число, квадрат которого равен заданному: 1)6241 ; 2)15129; 3)974169; 4)152399025:...
syrlybai056
24.06.2020 19:25
Задание в Excel. 1. Рассчитайте прибыль по данным и формулам Таблицы 2. Проанализируйте с ТП, как влияет на прибыль изменение параметров Количество в диапазоне от 8% до...
irinkailnitska11
25.06.2020 07:22
Полный путь к файлу: С\202\Практические работы \ Практическая работа № 3.doc. Каково имя файла? 1.Практическая работа № 3 2.202\Практические работы \ Практическая работа...
sweetmayers
24.06.2020 19:31
ХЕлпаните Коды языка HTML, с которых выполняется разметка исходного текста, называются: А) операторами В) служебными словами С) тегами Д) ASCII-кодами 2. Документ, содержащий...
Лиза200111111
25.06.2020 18:12
В одном автобусе ехали на конференцию 4 ученых: Иванов, Петров, Кошкин и Чашкин. Среди них были историк, биолог, физик, химик. Каждый взялся прочитать доклад коллеги. Все...
AdinaKhamzina1
07.09.2019 14:27
Объясните, как это получилосьupdate: сам разобрался, пока публиковал вопросupdate2: как удалить...
Adik20061
23.07.2019 04:20
Запиши проверочные слова,вставь, если необходимо,буквы. грустный местность поздно окресность вкус ный звёзды честный слёз ный опас ный серьёзный...
Популярные вопросы
Запишите десятичные дроби в виде обыкновенных 6,6: 78,04; 0,0007; 0,0789;...
3
Эпитеты из сказки а. с. пушкина сказка о мертвой царевне и о 7 богатырях...
1
Прочитайте текст с какими утверждениями автора вы согласны подберите...
2
Ссочинением, сочинение книги которые я перерос . примерно на 1 лист....
3
Выполнить синтаксический разбор предложения: для меня сделали исключение,и...
3
Можно ли вписать в ромб окружность?...
2
Надо выписать номера правильных утверждений. ) 5)треугольники подобны,...
1
Упети было меньше 100 маленьких кубиков с ребром 1 см. когда он из них...
3
Укажите сложное предложение, части которого соединены союзом и. (знаки...
2
Нужно написать 4-6 предложений с приложением, то есть с определением,...
3
a,b,k,s: integer;
begin
k := 0;
a := 1;
b := 1;
while b < 1000 do
begin
if b >= 100 then
begin
s := b div 100 + b div 10 mod 10 + b mod 10;
if b mod s = 0 then
k := k + 1
end;
b := a + b;
a := b - a;
end;
write(k)
end.