Составить программу. дано натуральное число n. подсчитать количество цифр этого числа.

mironova161 mironova161    1   23.06.2019 16:30    0

Ответы
DetasGames DetasGames  19.07.2020 13:23
Var
  n: longint;
  s: string;
  k: byte;

begin
  Write('Введите натуральное число '); Readln(n);
  { Преобразуем число к строке, убрав знак (мало ли...) }
  Str(abs(n), s);
  { Выведем длину полученной строки }
  Writeln('Количество цифр в числе равно ', Length(s))
end.

Тестовое решение:
Введите натуральное число 164275353
Количество цифр в числе равно 9
ПОКАЗАТЬ ОТВЕТЫ
ЮлияМезина ЮлияМезина  19.07.2020 13:23
Program chisla;
uses crt;
var a,b,c: integer;
begin
writeln('Введите натуральное число: ');
readln(a);
b:=a;
c:=0;
while b <>0 do
begin
c:=c+1;
b:= b div 10;
end;
writeln('B числе ',a,' - ',c, ' цифр');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика