Составить программу дано число м (м< =12). определить количество дней в данном месяце.

vaxa12345 vaxa12345    2   01.10.2019 04:30    3

Ответы
даша55516 даша55516  27.08.2020 10:41

Ну... а что сложного? Создаёшь структуру, заполняешь её, и обрабатываешь условие на входном M:


#include <stdio.h>

#include <conio.h>

#include <locale.h>

int main(void) {

setlocale(LC_ALL, "russian");

struct months {

 char name[16];

 int days;

};

struct months m[12] = {

 {"Январь",   31},

 {"Февраль",  29},

 {"Март",     31},

 {"Апрель",   30},

 {"Май",      31},

 {"Июнь",     30},

 {"Июль",     31},

 {"Август",   31},

 {"Сентябрь", 30},

 {"Октябрь",  31},

 {"Ноябрь",   30},

 {"Декабрь",  31}

};

 

int M;

 

printf("Введите номер месяца: ");

scanf("%d", &M);

 

if (M > 0 && M < 13) {

 M--;

 

 if (m[M].days == 29 || m[M].days == 30) {

  printf("В месяце \"%s\" %d дней.", m[M].name, m[M].days);

 } else {

  printf("В месяце \"%s\" %d день.", m[M].name, m[M].days);

 }

} else {

 printf("Неизвестный месяц.");

}

 

getch();

 

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика