Составить программу: дан массив из n элементов, посчитать произведение положительных элементов ..

Cektumcempra Cektumcempra    3   19.09.2019 08:10    1

Ответы
890ZLO168 890ZLO168  08.10.2020 01:48
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Writeln('Произведение положительных элементов равно ',
      a.Where(x->x>0).Aggregate(BigInteger(1),(p,q)->p*q))
end.

Составить программу: дан массив из n элементов, посчитать произведение положительных элементов ..
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика