Составить программу(10класс): дано предложение,заменить в нем все запятые на точки и удалить из предложения подстрочку по запросу пользователя.

Qmpzaslk Qmpzaslk    1   26.06.2019 04:50    2

Ответы
ekserukhova16 ekserukhova16  02.10.2020 11:55
uses Crt;
 var  Stroka, PodStroka: string;
     poz, i: integer;
begin
 ClrScr;
 Write(' Stroka :   '); ReadLn (Stroka);
 for i:= 1 to length (Stroka) do
     if Stroka[i]=',' then Stroka[i]:='.';

 WriteLn(' Zamena :   ', Stroka);
 WriteLn;
 Write(' PosStroka :   '); ReadLn (PodStroka);
 poz:=Pos(PodStroka, Stroka);
 Delete (Stroka,poz,length(PodStroka));
 WriteLn(' Udalili :   ', Stroka);
 ReadLn;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика