Составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и
произведение отриц.

Walker95 Walker95    2   07.03.2019 22:30    3

Ответы
Кари15142 Кари15142  24.05.2020 04:13

var a:array[1..10] of integer;

i,s:integer;

Begin

  randomize;

  for i:= 1 to 10 do begin

    a[i]:= random(100);

    s:=s+a[i];

  end;

  writeln(s);

End.

 

var a:array[1..10] of integer;

i,mk,pk,s,p:integer;

Begin

  randomize;

  p:=1;

  for i:= 1 to 10 do begin

    a[i]:= random(30+10)-10;

    if a[i]>=0 then begin

      pk:=pk+1;

      s:=s+a[i];

    end

    else begin

      mk:=mk+1;

      p:=p*a[i];

    end;

   

  end;

  writeln(pk,s,mk,p);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика