tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить листинг программы
Составить листинг программы в паскале ввести файл f из 11 элементов. определить в нём количество тех элементов, которые при делении на 3 остаток 2.
galina060876
2 26.07.2019 05:20
3
Ответы
жееннняяя
03.10.2020 13:13
//Pascal ABC.NET v3.1 сборка 1172
Var
f:text;
i,k,a:integer;
begin
assign(f,'text.txt');
reset(f);
for i:=1 to 11 do
begin
read(f,a);
if a mod 3=2 then inc(k);
end;
close(f);
writeln(k);
end.
Данные в файле text.txt:
1 2 3 4 5 6 7 8 9 10 11
Пример вывода:
4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
asti2000
23.06.2020 17:22
Где применяется компьютер внутри человека?...
Alexey2005201937
22.06.2020 17:57
Информация. Виды и свойства информации.2. Измерение информации. Содержательный и алфавитный подходы3. Кодирование текстовой информации4. Кодирование графической информации5....
Электрик2016
23.06.2020 17:10
Результат виконання команди 55 div 6*55 mod 6....
tolkov05
22.06.2020 18:51
Попадает ли точка в заштрихованную область, если да, то вывести TRUE. Pascal...
ВероникаФардзинова
22.06.2020 19:00
Записать математическое выражение на языке Паскаль...
egorgamer153
01.04.2019 02:20
Составить 3 любых алгоритма что то типо того : налить чай 1) начало. 2) взять кружку. 3) налить заварку. 4) положить сахар. 5) налить кипяток. 6) размешать. 7) конец....
thedesxte
14.01.2021 12:47
Петрик пройшов Х год зі швидкістю 5 км/год, а Катерина У год зі швидкістю 4 км/год.Складіть математичну модель і проект для визначення хто з них пройшов більшу відстань коли...
stas952011217217
14.01.2021 12:46
создать программу В программе Python...
HappyEnot
03.09.2019 09:00
11. составить программу, осуществляющую ввод числовых переменных. если число положительное, то вывести соответствующую информацию и выйти из программы. если число отрицательное,...
palnikov2000
03.09.2019 09:00
10. составить программу, осуществляющую ввод числовых переменных. при вводе положительного числа вывести информацию: «число больше ноля», при вводе отрицательного числа – «число...
Популярные вопросы
Из за чего началась война в афганистане желательно подробно всё описать...
2
Когда родители контролирует выполнение детьми , то они выполняют: выберите...
2
Почему воздух не нагревается непосредственно от падения прямых солнечных лучей...
2
Какие прилагательные пишутся слитно, а какие раздельно? 1.(не)продолжительное...
3
Почему валика и марусю можно назвать обездоленными рассказ: в дурном обществе...
3
Засеяли 65% поля что составило 325 га найдите площадь всего поля...
2
F(x)=sin5x-x найти общий вид первообразной...
1
нужен только чертеж внешний угол равнобедренного треугольника равен 130градусов.найдите...
1
Разность 45. 643 и неизвестного числа равна частному чисел 5850 и 15 найди...
3
Какой бы стало жизнь если бы все люди всегда следовали 10 заповедям...
1
Var
f:text;
i,k,a:integer;
begin
assign(f,'text.txt');
reset(f);
for i:=1 to 11 do
begin
read(f,a);
if a mod 3=2 then inc(k);
end;
close(f);
writeln(k);
end.
Данные в файле text.txt:
1 2 3 4 5 6 7 8 9 10 11
Пример вывода:
4