Составить линейную программу, печатающую значение true, если указанное высказывание является истинным, и false — в противном случае. цифры данного трехзначного числа n являются членами арифметической прогрессии. 2 составить программу с ветвлением, печатающее слово ‘да’, если указанное высказывание является истинным, и ‘нет’ — в противном случае. язык с++. надо с обьяснениями

ruzmat84ot4xqh ruzmat84ot4xqh    1   05.10.2019 19:40    9

Ответы
yanamosijchuk yanamosijchuk  09.10.2020 22:19

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

int number; //Вводимое число

int difference_first, difference_second; //переменные проверки арифм. прогр.

cout << "Enter three digit number: "; cin >> number; //ввод трехзначного числа

while(number < 100 or number >= 1000){

 //проверка числа на трехзначность

 cout << "Error!\nEnter three digit number: "; cin >> number;

}

 difference_first = number % 10 - (number / 10 % 10); //разница между третьей цифрой и второй

 difference_second = (number / 10 % 10) - (number / 100 % 10); // разница между второй цифрой и первой

   if(difference_first == difference_second){ // если эти разницы равны, значит

    cout << "YES!" << endl;       // вывод, ДА

   }else cout << "NO!" << endl;      // иначе, НЕТ

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика